Division in Query mittels lokalem Feld

Division in Query mittels lokalem Feld

Postby Jette3720 » Thu Apr 05, 2007 9:06 am

Hallo,

ich hab folgendes Problem.

Ich habe eine SAP-Query erstellt. Dabei habe ich lokale Felder verwendet, in denen ich einzelne Felder berechnen lasse. Dabei habe ich ein lokales Feld indem ich eine Division durchführe. Mit dem Ergebnis bin ich aber nicht ganz zufrieden :-)

Das lokale Feld hat folgende Einstellungen:

Eigenschaften:
Rechenfeld: Anzahl der Ziffern 10 Dezimalstellen: 2

Berechnungsvorschrift:
100 / 1000

Also ein ganz einfaches Beispiel.
Als Ergebnis zeigt er mir aber 0,00 an statt 0,1.
Wenn ich 1000 / 100 dann stimmt das Ergbnis mit 10.

Er verschluckt mir irgendwie die Nachkommastellen. Wenn ich 10 / 1000 * 1000 eingebe, kommt auch Null raus, statt 10. Hab ich einen falschen Datentyp ? Oder hängt das an den Dezimalstellen ? Aber wenn ich 0 Dezimalstellen eingebe, dann zeigt er halt keine Nachkommastellen an....

Ich hoffe ich habe es ausreichend beschrieben, ansonsten mache ich gerne weitere Angaben.

Vielen Dank für Eure Hilfe....

Oli
Jette3720
..
..
 
Posts: 18
Joined: Thu Apr 05, 2007 9:06 am

Postby Jette3720 » Mon Apr 30, 2007 10:09 am

Hallo,

ich konnte das Problem dank HELWIE erfolgreich lösen. Viele Dank dafür. Anbei die Ursache des Problems:
Der Trick liegt im InfoSet der Query versteckt. Damit das Query richtig rechnen kann, ist es erforderlich, dass im InfoSet im Menü unter "Springen" "Globale Eigenschaften" die "Festpunktarithmetik" eingestellt ist. Sollte dies bereits geschehen sein, funktionierte es bei mir, als ich das Häckchen erst einmal wieder entfernt, das InfoSet neu generiert und anschließend wieder neu gesetzt habe.

Für die Nachwelt :-)

Gruß
Peter
Jette3720
..
..
 
Posts: 18
Joined: Thu Apr 05, 2007 9:06 am


Return to Sonstige Module BW, SRM, Berechtigung etc.

Who is online

Users browsing this forum: No registered users and 1 guest

cron
  • Latest Topics